Telleroo status - Payments showing at awaiting funds with enough balance in the account. – Incident details

All systems operational

Payments showing at awaiting funds with enough balance in the account.

Resolved
Degraded performance
Started about 1 month agoLasted 23 minutes

Affected

Payments

Degraded performance from 5:45 AM to 6:08 AM

GBP

Degraded performance from 5:45 AM to 6:08 AM

FX

Degraded performance from 5:45 AM to 6:08 AM

Updates
  • Postmortem
    Postmortem

    Technical Update: Processing Delay Resolved
    We recently identified and corrected a technical synchronisation issue that caused a temporary delay for a small percentage of payment transactions.
    Issue Overview
    The delay was linked to a recent system optimisation intended to enhance transaction security and prevent processing errors. While the update performed its primary security function, it created an unintended bottleneck in one of our automated workflows. This resulted in some transactions failing to advance to the final processing stage automatically.
    Resolution & Current Status
    Our engineering team has implemented a permanent fix to restore full automation across all processing pathways.

    • Immediate Mitigation: During the resolution window, we utilised a background process to ensure all affected transactions were identified and successfully processed.

    • System Correction: A logic update has been deployed to ensure that our enhanced security protocols and automated processing workflows function in perfect alignment.

    • Current Status: All systems are operating normally, and the backlog of affected payments has been cleared.

  • Resolved
    Resolved

    This incident has been resolved, all payments have been sent and will be in the recipients bank account within the 2 hour faster payment timescle if not already.

  • Monitoring
    Monitoring

    Our team have resolved the issue and payments are now being sent.

  • Identified
    Identified

    Our team have identified the issue affecting a small subset of payments and working on a fix.

  • Investigating
    Investigating
    We are currently investigating this incident.